Back
Maintenance

SSL replacement
Completed 18 Jun at 11:59pm EDT.
Updated
We had a minor follow-up issue related to the SSL replacement which has now been verified and fixed. We will be conducting a follow-up debrief in this regard.
Service is now fully operational.
Posted
19 Jun at 01:31am EDT.
Completed
Maintenance completed
Posted
18 Jun at 11:59pm EDT.

Started
Switch over an expiring SSL certificate during nighttime on a weekend.
Posted
18 Jun at 08:00pm EDT.